[718/728] Matrix OPCODE FIXED source+cache+client bundle release


#41

Added 3rd mirror.


#42

When I launch the run.bat in the source folder I get this error
What do i need to do to fix this?

[Launcher] Initing Cache…
[Launcher] Initing Data Files…
[Launcher] Initing Fishing Spots…
[Launcher] Initing NPC Combat Scripts…
[Launcher] Initing Dialogues…
[Launcher] Initing Controlers…
[Launcher] Initing Cutscenes…
[Launcher] Initing Friend Chats Manager…
[Launcher] Initing Cores Manager…
[Launcher] Initing World…
[Launcher] Initing Region Builder…
[Launcher] Initing Server Channel Handler…
ERROR! THREAD NAME: main
org.jboss.netty.channel.ChannelException: Failed to bind to: 0.0.0.0/0.0.0.0:435
94
at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:2
98)
at com.rs.net.ServerChannelHandler.(ServerChannelHandler.java:49)
at com.rs.net.ServerChannelHandler.init(ServerChannelHandler.java:28)
at com.rs.Launcher.main(Launcher.java:101)
Caused by: java.net.BindException: Address already in use: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Unknown Source)
at sun.nio.ch.Net.bind(Unknown Source)
at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(N
ioServerSocketPipelineSink.java:138)
at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handle
ServerSocket(NioServerSocketPipelineSink.java:90)
at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventS
unk(NioServerSocketPipelineSink.java:64)
at org.jboss.netty.channel.Channels.bind(Channels.java:569)
at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:187
)
at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBo
otstrap.java:343)
at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:170)
at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.(NioS
erverSocketChannel.java:80)
at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newC
hannel(NioServerSocketChannelFactory.java:158)
at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newC
hannel(NioServerSocketChannelFactory.java:86)
at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:2
77)
… 3 more
[Launcher] Failed initing Server Channel Handler. Shutting down…
Trykk en tast for å fortsette…


#43

are you still working on adding new things?


#44

Hey, I was wondering if someone could really help me! i really need some help! im starting to make my first rsps but i think i need a cache, i dont know anything of what im doing! if someone could help me that would be amazing thank you! if someone could use teamveiwer with me as well to make it easier i would be very very greatful!


#45

you can contact me on skype if you still need help getting a server up - loli8yourcat


#46

Hey, i’ve got everything up and working, just struggling with trying to wear Torva armour. It’s saying i need to vote blah blah blah. any information to link this to mySQL to get voting working or highscores however if you have the files to do it that would be awesome too. Would be much appreciated dude. Cheers


#47

When I run the client I get this error “The system cannot find the path specified” how do I fix this, thx in advance :-).


#48

[quote=“Ozank, post:20, topic:541663”][quote author=Decysp link=topic=660532.msg4418687#msg4418687 date=1397321099]

[/quote]

What do you prefer? Mediafire?[/quote]

Use Mega!


#49

I need help I keep getting

Error: missing server' JVM atC:\Program Files (x86)\Java\jre1.8.0_73\bin\serv
er\jvm.dll’.
Please install or use the JRE or JDK that contains these missing components.
Press any key to continue . . .

as an error, I have the most recent jdk and jre, so what’s the problem? I’ve also tried making a server file and placing jvm.dll and its companion files in it and it says -Xmx4096m is invalid??? please help a noob out


#50

going to try this one out, considering most of the source and client’s on here dont work and are from 2009+ :)… i have never posted anything up on here ever!, so i dont know what to say mostly apart from… cheers Matrix… this most is from 2014 so if your reading this then ill let you know how it is, if your not reading this and you found a life somewhere then happy days hahaha :)x


#51

[quote=“opo2, post:47, topic:541663”]When I run the client I get this error “The system cannot find the path specified” how do I fix this, thx in advance :-).[/quote] If your encountering this problem edit the compiler and run.bats to your java version run both compilers before launching server hope i helped if u need more detailed assistance pm me


#52

great work , but i have 2 qustions
1- im i the only one that have a bug ? when i try to attack any monster the char keep moving closer the hits the monster once and keep moving away and in the end for the end of the map ??? dose any one have any idea where to check the problem ?

2- how do i know for sure that my player is a admin ?? i saw how i change rights for chars but i dont know how to know if that worked for sure , thanx


#53

Can anyone help me set this up? Im kinda new. fast learner!


#54

If you’d actually explain what you’re having an issue with, we could help.